Click Start > Run
Issue
When you install or remove Adobe Acrobat, you receive a Windows error message stating suspended, incomplete or interrupted installation. The Acrobat installation fails, and the installer is unable to roll back the incomplete installation successfully.
Possible error messages include the following:
- "Error 1704. An installation of Adobe Acrobat or Adobe Reader is currently suspended."
- "Internal Error 2711. The specified feature name 'PatchExtras' not found in the feature table."
- "Error 1500. Another installation is already in progress. Complete that install before proceeding with this installation."
Cause
A power outage, premature system shutdown, or system issue causes the Windows installer corruption. Cancelled installations roll back the installation actions and do not result in a suspended installation.
Solution
To solve the error, perform one of the following steps:
Solution 1: Stop any in-progress installations
This procedure involves editing the Windows registry. Adobe doesn't provide support for editing the registry, which contains critical system and application information. Make sure to back up the registry before editing it. For more information about the registry, see the Windows documentation or contact Microsoft.
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Type regedit and click OK.
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Navigate to the key: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\ and check if Inprogress key exists.
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Delete the key and restart the installation.
Solution 2: Unregister and re-register the Windows Installer service.
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Click Start > Run
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Type msiexec /unreg and click OK.
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Click Start > Run
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Type msiexec / regserver and click OK.
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